Address Validation
Incident Report for NRG Software
Resolved
This incident has been resolved.
Posted Oct 03, 2018 - 18:02 UTC
Update
We are continuing to investigate this issue.
Posted Oct 03, 2018 - 18:01 UTC
Investigating
Numerous customers reported address validation issues. We researched and found that Endicia was having server issues but they have since been resolved.
Posted Oct 03, 2018 - 18:01 UTC
This incident affected: Carrier Integrations (Endicia APIs).