Validation issues
Incident Report for NRG Software
Resolved
Endicia has completed maintenance.
Posted May 27, 2020 - 19:04 UTC
Identified
Endicia is performing maintenance during business hours that is impacting their validation service. Maintenance is to be completed by Noon PST. http://status.endicia.com
Posted May 27, 2020 - 17:17 UTC
This incident affected: Carrier Integrations (Endicia APIs).