UPS Error 10429 Too Many Requests

Incident Report for NRG Software

Resolved

Please contact NRG support at 262-432-0934 or email support@nrgsoft.com if you are receiving this error.
Posted Jan 05, 2026 - 19:22 UTC

Update

This error looks to be intermittent. Please try to rate/ship again if you receive this error. We will update more once we get a response from UPS.
Posted Jan 05, 2026 - 16:21 UTC

Investigating

Customer report receiving this UPS error. UPS API status shows no issue, we have reached out to UPS for resolution.
Posted Jan 05, 2026 - 16:09 UTC
This incident affected: Carrier Integrations (UPS APIs).