Endicia outage
Incident Report for NRG Software
Resolved
Endicia reports all systems are operational.
Posted Jun 20, 2018 - 20:18 UTC
Monitoring
We are monitoring Endicia for updates.
Posted Jun 20, 2018 - 20:13 UTC
Investigating
Endicia is currently experiencing difficulties with a third-party provided which is impacting solutions like NRGship for rating, shipping and validation. status.endicia.com
Posted Jun 20, 2018 - 20:13 UTC
This incident affected: Carrier Integrations (Endicia APIs).